EPS system limited browser support 2017-05-11T20:42:20+00:00

EPS system limited browser support

Please note: You will require the most current versions of Internet Explorer 11 or Firefox to submit your Employer Payroll Statement electronically,

Google Chrome and Safari browsers are not compatible with our online submission system.

Mobile devices or tablets cannot be used for submitting your Employer Payroll Statements.

If you have any questions, please contact the webmaster.